$vboptions[bbtitle]

Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 27

Thread: Norinco M14 Failure to Eject Video - Please Help.

  1. #11
    Member NilRecurring's Avatar
    Join Date
    Oct 2013
    Location
    BC
    Posts
    82
    I had ejection issues recently shooting my m305. Was using a mix of Winchester and Remington .308 from Canadian Tire, a mix of FMJ and softpoints. Had two or three failures to eject and I'm not sure what would cause it.

    Edit: using a fresh CASM mount and I wonder if that had anything to do with it.
    Last edited by NilRecurring; 08-24-2015 at 02:03 PM. Reason: Failure to deliver information

  2. #12
    Newbie napalmdeath's Avatar
    Join Date
    Jun 2009
    Posts
    24
    Please have a good reading at the Sticky concerning the M14/M1A/M305 in the Main Battle rifle forum.
    Maybe a need for the ejector mod, so the empty cases eject less high & more on the side.
    My thousand of minute of angle of honest 2 cents opinion...

    Quote Originally Posted by jfilion2 View Post
    https://www.youtube.com/watch?v=VJMaBgEZ7z8

    I've included a link to a video I shot today, shooting a stock Norinco M305 with 7.62x51 NATO ammo. First 30 seconds at regular speed, second 30 seconds in slow motion. It worked fine until I mounted a scope bracket.

    Shot 25 rounds at 100 yards. 1 means reload success, 0 represents failure to reload.

    10010 11000 11010 11011 11100

    44% chance of failure to reload. Ouch!

    Please help. I want to love this gun.

    Jean

  3. #13
    Super GunNutz rodauto's Avatar
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    411
    Quote Originally Posted by NilRecurring View Post
    I had ejection issues recently shooting my m305. Was using a mix of Winchester and Remington .308 from Canadian Tire, a mix of FMJ and softpoints. Had two or three failures to eject and I'm not sure what would cause it.

    Edit: using a fresh CASM mount and I wonder if that had anything to do with it.
    I have 3 different M14 style rifles with the Casm mount, never have had a problem with ejection on any of them. Did have problems with an NC star mount that came with one of my rifles. Took it off after the first day!


    Rodney

  4. #14
    CGN Regular aakoksal's Avatar
    Join Date
    Jan 2008
    Location
    Calgary
    Posts
    534
    Looks like extractor not grabbing the shell. If removing scope mount won't fix it, inspect the extractor as well.

  5. #15
    CGN Regular
    Join Date
    Dec 2012
    Location
    Ontario
    Posts
    565
    the case is being extracted....

  6. #16
    Super GunNutz rodauto's Avatar
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    411
    Quote Originally Posted by cranswick View Post
    the case is being extracted....
    When I had the NC Star mount on my rifle it was recommended by others that the only way to reduce the extration issue was to remove some metal from the bottom of the mount. Don't know how much would have been necessary but I could see where the casings were hitting so would have removed some metal in those areas. Didn't bother as I had the Casm mount on order by then.

    Rodney

  7. #17
    Newbie joe09's Avatar
    Join Date
    Oct 2012
    Posts
    21
    Try with and without the rail .

  8. #18
    CGN Regular
    Join Date
    Jul 2010
    Location
    COKL Bantario
    Posts
    771
    If she ran fine without that mount. And starting to shi.t the bed with it id say it's the mount. Get an arms 18 and be done with it. Mount any scope you want in qd rings and keep the irons as back up.
    Quote Originally Posted by Rocket Surgery View Post
    Just put some cream on it

  9. #19
    CGN Regular
    Join Date
    Dec 2012
    Location
    Ontario
    Posts
    565
    Quote Originally Posted by rodauto View Post
    When I had the NC Star mount on my rifle it was recommended by others that the only way to reduce the extration issue was to remove some metal from the bottom of the mount. Don't know how much would have been necessary but I could see where the casings were hitting so would have removed some metal in those areas. Didn't bother as I had the Casm mount on order by then.

    Rodney
    you guys mean ejection then...two different things.

  10. #20
    Newbie DieselDan6.2's Avatar
    Join Date
    Sep 2013
    Posts
    3
    Try playing with different kinds of ammo. I had this same issue until I put hornady 125 gr through it and haven't had a failure to eject. Still jams with the heavier loads but it's a quick and cheap fix to the problem

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •