$vboptions[bbtitle]

Page 3 of 3 FirstFirst 123
Results 21 to 27 of 27

Thread: Norinco M14 Failure to Eject Video - Please Help.

  1. #21
    CGN Regular
    Join Date
    May 2015
    Posts
    238
    These guns like to chuck the spent cartridges forward.

  2. #22
    CGN Regular slyty's Avatar
    Join Date
    Sep 2009
    Location
    N.E. Saskatchewan
    Posts
    256
    Does it pass the tilt test?
    Freedom doesn't mean safe. It means free

  3. #23
    Super GunNutz rodauto's Avatar
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    410
    Quote Originally Posted by cranswick View Post
    you guys mean ejection then...two different things.
    Thanks, yes I meant ejection.
    Rodney

  4. #24
    Newbie
    Join Date
    Aug 2015
    Posts
    4
    Okay all, I received the CASM mount last week.

    I have put 300 rounds through it.

    Zero, I'm serious, 0 blockages.

    Works like a freaking Champion. Didn't clip the spring or do any other changes. The mount fixed my issue.

    Much love to M14.ca for this, Jean.

  5. #25
    Super GunNutz rodauto's Avatar
    Join Date
    Mar 2012
    Location
    Ontario
    Posts
    410
    Quote Originally Posted by jfilion2 View Post
    Okay all, I received the CASM mount last week.

    I have put 300 rounds through it.

    Zero, I'm serious, 0 blockages.

    Works like a freaking Champion. Didn't clip the spring or do any other changes. The mount fixed my issue.

    Much love to M14.ca for this, Jean.
    Canadian magic!!! Doesn't get any better, glad it fixed your problem. These rifles are just too much fun to deal with functioning issues.

    Rodney

  6. #26
    CGN Regular Reaper665's Avatar
    Join Date
    Dec 2010
    Location
    White Water Region, Ontario
    Posts
    835
    Quote Originally Posted by jfilion2 View Post
    Okay all, I received the CASM mount last week.

    I have put 300 rounds through it.

    Zero, I'm serious, 0 blockages.

    Works like a freaking Champion. Didn't clip the spring or do any other changes. The mount fixed my issue.

    Much love to M14.ca for this, Jean.

    Ok well now I'm going to have to order one. I have a promag mount and as a previous fella mentioned, it is next to impossible to sight in.

    Thanks for sharing.
    Last edited by Reaper665; 09-06-2015 at 08:12 PM. Reason: Order in!
    ΜΟΛΩΝ ΛΑΒΕ
    "Lions need not concern themselves with the opinions of lambs"
    Member of CCFR.
    kindly add photos to your EE ad

  7. #27
    CGN Regular
    Join Date
    Oct 2005
    Posts
    159
    Your solution is in the sticky thread as mentioned above.

    Trim your ejector spring.
    It has nothing to do with adjusting "gas" or an "overpowered mainspring". 1-2 coils at a time as this will alter the angle at which the case ejects. If that doesnt work, replace with an aftermarket ejector spring and ejector plunger and repeat the same process until you get the angle just right.

Page 3 of 3 FirstFirst 123

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •