CanadianGunNutz.com logo, Firearms News and Classifieds in Canada

Page 2 of 2 FirstFirst 12
Results 11 to 13 of 13

Thread: Blue Line Warranty Suport

  1. #11
    CGN Ultra frequent flyer Can-down's Avatar
    Join Date
    Apr 2005
    Location
    B.C.
    Posts
    17,487
    It's a pretty heavy bolt allready, my gun does not seem to be showing any signs of battery, the firing pin channel must have some sort of machining error or rough spots though as it is peening the shoulders of the firing pin where it tapers down. Jard sent me a new firing pin which looked better made then the first one but after about 40 shots it's getting peened by what ever is in the channel. It can't be helping with ignition but the fact it allways fires nice with a deep hit the first shot after manually cycling the action is a bit strange, Dean from Jard said he shipped a new bolt 3 weeks and when it arrives I will take the gun out for another attempt just in case the bolt's firing pin channel issue is causing my second shot light strikes.
    Our Government trusts rivets more then law abiding gun owners.

  2. #12
    CGN Regular Forty4Forty's Avatar
    Join Date
    May 2004
    Location
    Saskatoon, Saskatchewan
    Posts
    726
    rhetorical question: Do you answer your emails, apparently not.
    ďAll political power comes from the barrel of a gun. Our principle is that the Party commands the gun, and the gun must never be allowed to command the Party.Ē Ė Mao Zedong

  3. #13
    CGN Regular Jest4phun's Avatar
    Join Date
    Feb 2018
    Location
    Alberta
    Posts
    514
    Quote Originally Posted by Can-down View Post
    It's a pretty heavy bolt allready, my gun does not seem to be showing any signs of battery, the firing pin channel must have some sort of machining error or rough spots though as it is peening the shoulders of the firing pin where it tapers down. Jard sent me a new firing pin which looked better made then the first one but after about 40 shots it's getting peened by what ever is in the channel. It can't be helping with ignition but the fact it allways fires nice with a deep hit the first shot after manually cycling the action is a bit strange, Dean from Jard said he shipped a new bolt 3 weeks and when it arrives I will take the gun out for another attempt just in case the bolt's firing pin channel issue is causing my second shot light strikes.
    Iím having a similar issue with mine I think my issue is with my trigger to be honest I usually see light strikes after I get 60ish rounds in. Itís like the timing is always off on mine trigger sucks itís light but I canít dump a mag for my life as it catches somewhere along the way on the reset and then I gotta pull twice to get the hammer to fall once. When my new spring and firing pin came I still had the issues but a new one popped up for me as It started to 3 round burst mode, I took it out a second time after cleaning to see if I could replicate the problem and after 60rds in it start to burst fire again so Iím guessing itís mainly due to it getting dirty somewhere along the way. I pretty much put it down for a bit since then itís a cool concept bullpup bottom ejecting but.......one of those moments I regret as I wanted it to work out of the box but now itís sitting in the safe wondering if I need to spend more money on a new firearms to get it to work properly pretty much spend money to send it to blueline to see whatís up.

Page 2 of 2 FirstFirst 12

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •