CanadianGunNutz.com logo, Firearms News and Classifieds in Canada

Page 15 of 20 FirstFirst ... 57891011121314151617181920 LastLast
Results 141 to 150 of 197

Thread: IN-STOCK NOW: SS-211 12ga

  1. #141
    Member
    Join Date
    Jul 2020
    Posts
    35
    Quote Originally Posted by stevo911_ View Post
    That would be the perfect shell for these, but alas they've said no a number of times
    Right! Such a good idea !

  2. #142
    Newbie
    Join Date
    Feb 2009
    Location
    North Western Ontario
    Posts
    25
    Also have the auto engage safety issue, didn't start till around the 20 shell point. Happening with anyone that shoots it so i don't think its being bumped by accident.

  3. #143
    CGN Ultra frequent flyer J.Hancock's Avatar
    Join Date
    May 2019
    Location
    Guelph
    Posts
    2,928
    Shoulda put like 3 or 4 barrels on this puppy
    "When truth and fairness differs from what is law, better to follow truth and fairness."

  4. #144
    Super GunNutz hsatimmy's Avatar
    Join Date
    Nov 2013
    Location
    Niagara
    Posts
    3,232
    Quote Originally Posted by J.Hancock View Post
    Shoulda put like 3 or 4 barrels on this puppy
    yeah wheres our canadian triple crown
    Support the legal challenges. I recommend in order: Christine Machine/S74 appeals , ATRS lawsuit, remainder.
    https://www.gofundme.com/f/s74-appea...rce=customer&u tm_campaign=p_lico+share-sheet[/url]
    https://www.gofundme.com/f/ejrdm-cla...pd+share-sheet

  5. #145
    CGN Regular
    Join Date
    Jul 2019
    Location
    Montreal, Québec
    Posts
    102
    Quote Originally Posted by BIG SHOOTZ View Post
    I took mine out again today, and want to share a few things.

    3 separate shooters we all had the same issue with the safety engaging, I personally watched my buddy shoot and after first round it came on and he was no where near it, so a few models must have the safety issue!

    Second I am now seeing what appears to be a failure in the chamber of the top barrel started off as a small scratch or machining mark it has no looped the interior of the chamber and the whole top chamber looks rough IMO

    3rd cleaning it tonight it appeared to be flaking out a chrome lining, mainly front of the chamber before the barrel starts.

    anyone have pointers to offer on how to post pics,
    I'll try and figure out how to post pics on here I'm still learning this forum.

    little shotgun is a riot to plink with just hoping to get it figured out

    **Image and video linking functions will be enabled after you have contributed more to the forum**
    **Image and video linking functions will be enabled after you have contributed more to the forum**
    **Image and video linking functions will be enabled after you have contributed more to the forum**
    you could use https://imgbb.com/

  6. #146
    Member
    Join Date
    Jun 2018
    Location
    Nova Scotia
    Posts
    60
    Had mine out yesterday. After a few shots it decided it would fire both barrels at the same time. It did this twice in a row.

    There’s the possibility the selector wasn’t fully engaged, so I cycled the safety and cycled the selector and it didn’t happen again.

  7. #147
    CGN Regular
    Join Date
    Jul 2012
    Location
    Vancouver
    Posts
    393
    lol

  8. #148
    CGN Ultra frequent flyer guess_kto's Avatar
    Join Date
    Jun 2004
    Location
    Brantfort, ON
    Posts
    7,176
    Cute luttle gun, but I wish it had ejectors. The breach need help to open anyway, so kicking out empty shells would be a plus. Anyway, nice gun to have.
    "Laws that forbid the carrying of arms ... disarm only those who are neither inclined nor determined to commit crimes." - Thomas Jefferson, 1775.

  9. #149
    BANNED
    Join Date
    Sep 2021
    Location
    Northern BC
    Posts
    486
    TI I spoke with over the phone explained my issue's and was told to shoot them a few pics by email and to send it in for replacement. Just waiting for my reply email

  10. #150
    CGN Regular Stranger's Avatar
    Join Date
    Apr 2004
    Location
    Calgary
    Posts
    521
    I can also confirm the problem with trigger on the second shot.

    There is a consistent issue of NOT firing off the second shot with slugs in both barrels. Even mild loads reproduce the same pattern:
    - Safety is NOT touched or engaged during or after the first shot, visibly OFF
    - trigger freezes and no amount of (reasonable) force helps to produce the SECOND shot
    - fiddling with safety ON / OFF doesn't help either
    - breaking action open and closing it back is THE ONLY WAY to fire the second barrel.

    Ammo used - Federal 1-3/4 mini slugs (1200fps, 1.75").
    20+ rounds fired, only ONCE both barrels fired as it should be!

    Federal 1-3/4 buckshot worked fine, so the issue is apparently RECOIL-related. And it has nothing to do with external safety.

    Any ideas?

    s>

    PS Sent this info to TI via Contact page on their website.
    Last edited by Stranger; 09-29-2021 at 02:45 PM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •